Product and Development Musings

ImageMan.Net Twain Now Compatible with .NET 4.0 and Visual Studio 2010

20. May 2010 06:35

Good news, early adopters! ImageMan.Net Twain 2.80, the latest release of our advanced Twain component, fully supports the .NET framework 4.0 and Visual Studio 2010.   This component is now available for downloading from the My Products page.

Separate Assemblies

ImageMan.Net Twain 2.80 ships with two separate DLL's- one for the .NET framework 2.0 and one for the .NET framework 4.0.  You'll find the DLL's in separate folders in the installation path.

Note: You can tell the difference between the similarly named DLLs by right clicking on the file and viewing the Properties dialog.  In the Details tab (for Windows 7) or the Version tab (for XP), view the File description field.  The 2.0 assembly will read "ImageMan.Net Twain for .Net 2.0".  Likewise, the 4.0 assembly will be labeled "ImageMan.Net Twain  for .Net 4.0". 

2010-05-19_1400

Sample Applications and Code

You'll notice new client side and ASP.NET samples (and sample code) that are fully compatible with Visual Studio 2010.  If you have multiple versions of Visual Studio on your system, you can select which samples to install during the installation process. 

Note: The Start menu links to the demo apps will always target the earliest version of the .NET framework you have installed on your computer.

2010-05-14_1042 

Help Format

To better integrate with Visual Studio 2010, we've updated our documentation to the Microsoft Help System format which is available to you when you install Visual Studio 2010.  Previous versions still retain their properly formatted help documentation.

2010-05-14_1049

Log in